View Issue Details

IDProjectCategoryPrivateLast Update
0005009Battlefield 1Controls/InputNo2018-03-07 11:32
Status ClosedResolutionUnable to Reproduce 
Product VersionUpdate 30012018 - North Sea Update 
Fixed in Version 
Summary0005009: Airship freelook

Freelook in the airship is configured wrong. Instead of using the freelook keybinds it works like this:

Looking left/right is set on roll left/right
Looking up/down is set on pitch up/down

Now that is fine for players using default controls but I use A and D for roll. W and S for pitch up/down.
This makes properly flying the airship impossible.

I also noticed you now cannot bind the mouse axis ingame. It does work in the main menu.

Actual Result
Expected Result



2018-03-07 11:32


Closing as we were unable to reproduce. If you have further details/information please feel free to re-open.