View Issue Details

IDProjectCategoryPrivateLast Update
0004592Battlefield 1FunctionalityNo2018-02-09 11:15
ReporterGirtablulu 
SeverityMajorReproducibilitySometimes 
Status QA InvestigatingResolutionOpen 
PlatformPC -OSWindows 
Product VersionUpdate 12102017 - October Update 
Fixed in Version 
Summary0004592: joining friends now absolutely impossible
Description

Before the patch, my friends would show in the sidebar in the main menu but without any option to join them or invite them for a party. So i always alt-tabbed, opened origin and joined/invited them via the origin client.

Something as basic as joining someone via the main menu not working since launch is one thing, but then breaking the only other way to get around it?

Just stop it with the monthly patches already, how is it still not clear that it's not giving the intended results?

With every monthly patch it's clear that it wasn't tested enough, or perhaps not even tested at all. I'd rather have to wait for a big patch that releases with every dlc and which fixes more big issues than it causes. than have it the other way around. Quality over quantity.

https://redd.it/75xsqn

Actual Result
Expected Result

Relationships

has duplicate 0004635 Closed Failed to join game. Server cannot be found. 
has duplicate 0004703 ClosedEA_RedSpoder Unable to join on friends 

Activities

TrackerBugger

2017-10-12 23:44

Registered User
  ~0005295

Yes joining friends in the sidebar ingame is not possible anymore

Someguy12121

2017-10-28 03:08

Registered User
  ~0005558

BUMP!!! This is STILL a HUGE issue!!!! Im on PS4 and this is game breaking cause a large portion of players play this game with friends and if you cant play with friends people go and play other games. Why is it that 2 months after this issue and no one from the Dev team has come in and AT LEAST confirmed this issue?

imajor

2018-02-06 12:11

Registered User
  ~0006181

I agree that this is important. I spend about 10-15 minutes every time I want to play the game by just trying to get into the same server as my friend. Often we end up with a situation where one of us plays on a server, the other one is still in the menu. So the one playing the game tells the other the server ID, and then the other one can search for that server in the server browser, and join there. It is guaranteed that at this time the server is full, so there is a queue which we need to wait for.

EA_RedSpoder

2018-02-06 14:00


  ~0006184

@TrackerBugger @Someguy12121 @imajor Can you let me know the exact steps you are taking here? I'd like to see if i can reproduce this issue on my side

imajor

2018-02-07 07:40

Registered User
  ~0006189

Last edited: 2018-02-07 07:49

View 2 revisions

@EA_RedSpoder This is how it was working yesterday:

  1. players A and B (both using windows 10, they are friends in origin) start Battlefield 1.
  2. player A invites player B into a party, B accepts. For both players the UI correclty reflects that they are in the party.
  3. Player A then goes to multiplayer>quick match>mixed servers. The game starts loading the map for player A.
  4. player B gets the message that the party leader is joining the server, and accepts by pressing and holding backspace (is this the correct way to accept the proposal? doesn't seems to be intuitive)
  5. the game didn't start loading for player B, there was no indication that anything would happen, it was just in main menu
  6. player B was looking for the play button on the right side of the screen next to player A in the party screen, but the button was not there, however the UI was correctly saying that player A is playing conquest on map X.
  7. player A send the server ID to player B, who was looking for the server in the server browser, and was trying to join. Immediate response: unknown error occurred. Even with join as spectator. This happened at least five times in a row.
  8. player B was looking at the party UI again on the right side, and now the small triangle play button was there next to player A, so player B was able to join.

Note that the server was not starting a new match when player A was joining, it was somewhere in the middle of a match.
Later the day we started playing again, and this time everything was working as expected. So this is not something happening 100% of the cases. I was surprised that we got the message saying that the party leader is joining a server, because I think in most of the cases it doesn't happen. I will keep watching for this, and post here any further information I can share. I can also send you any logs or screenshots or even videos if that helps.

EA_RedSpoder

2018-02-07 10:37


  ~0006191

Thanks for the update @imajor

imajor

2018-02-09 10:57

Registered User
  ~0006204

@EA_RedSpoder Some more update. Yesterday the first five items in the above list was the same. But after the failed attempt to join the party leader, the party UI showed the small play button next to the party leader which allows to join a friend. However pressing this button immediately gave the "unknown error occured" error message, I tried pushing it many times. Then I went back to the home screen of the main menu, where the first suggestion was to join my friend, how is playing on XY server. I pressed join there, and ir worked.

I had a feeling that the triangle shaped play icon next to the party leader was not correct. I think it was on the UI even before the party leader was joining the game, so it is possible that it had a reference to the previous server we played on (which we left just a minute ago because it became vacant)

imajor

2018-02-09 11:15

Registered User
  ~0006205

@EA_RedSpoder Can I send you a PM? I just realized that I have the session recorded as a video, maybe it would be helpful for you to check that.