View Issue Details

IDProjectCategoryPrivateLast Update
0004466Battlefield 1Controls/InputNo2018-01-05 12:09
Reporterkaristaja 
SeverityMajorReproducibilityRandom 
Status ClosedResolutionDuplicate 
PlatformConsoleOSPlaystation 
Product VersionUpdate 05092017 - In the Name of the Tsar Update 
Fixed in Version 
Summary0004466: Got revived and lost the ability to aim vertically.
Description

I got killed, then revived and lost the ability to aim up or down, could only aim horizontally.

Have a video of it but its 15 mins and needs to be edited down to just the issue.

Steps To Reproduce

Randomly from being revived

Actual Result
Expected Result

Relationships

duplicate of 0002963 Closed Aim Locking to X-Axis after Revive 

Activities

Armand Neculai

2017-09-12 21:39


  ~0005106

Please provide the video :D

AndreasPSN

2017-10-21 19:59

Registered User
  ~0005529

I've had this bug happen to me today, for the very first time if I'm not mistaken. I'm also on PS4, here's the clip:

https://www.youtube.com/watch?v=fm8tIl2H0SA

Someguy12121

2017-10-22 04:00

Registered User
  ~0005532

Ive also had this happen to me. It might be caused by certain actions that the player was doing before getting revived?

buum99

2017-10-22 23:11

Registered User
  ~0005535

Today I got similar bug. After being revived I couldn't aim up or down and I couldn't aim left or right too much either. It was like I would be in assault tank and I can move only about 90 degrees horizontal. I could move soldier but he always was directed in the same way. I went for AA gun and aim was ok, then I left AA gun I still was bugged until death. It was on Monte Grappa around D flag and I didn't use tank in this round. Unfortunatelly no proofs.

Foosjunky

2017-12-06 17:40

Registered User
  ~0005757

This happens on Xbox One as well. Here is a video I posted from July showing the behavior: https://www.youtube.com/watch?v=M20wtmsn5CA

Note how the gun is moving up and down but the crosshair does not move. This happened again last night which is what prompted me to visit the bug tracker and search for this issue. These are the only two times I've had this happen so occurrence rate is very low in my experience. (based on my playtime totals, twice in ~150hours of gameplay)

LumoColor

2017-12-07 11:33

Registered User
  ~0005764

Looks like the same issue as this.

https://youtu.be/xYt-BxzFzNw

  1. Jump wall.
  2. Get killed mid jump.
  3. When revived you get strange situation where you bounce around and cant do anything.
  4. Placing mortar fixes the jumping but you cant look up/down or prone in this example.

fabiode

2017-12-18 03:08

Registered User
  ~0005793

I think it's exactly when you get killed jumping a boulder or wall and then someone pumps you up, like LumoColor said. When you get revived, the bug turns BF1 on Doom 95.

Spitfire

2018-01-05 12:08


  ~0005941

0003742 is the master report for any erratic post-revive behavior now.

Spitfire

2018-01-05 12:09


  ~0005942

Also, duplicate of 0002963.