View Issue Details

IDProjectCategoryPrivateLast Update
0004358Battlefield 1UI/HUDNo2018-06-14 22:02
Reporterkaristaja 
SeverityMinorReproducibilityRandom 
Status ClosedResolutionUnable to Reproduce 
PlatformConsoleOSPlaystation 
Product VersionUpdate 21082017 - Lupkow Pass Update 
Fixed in Version 
Summary0004358: Sometimes classes spawn with the wrong model
Description

The first one i saw was an "assault" throw down a med crate before I noticed the medic icon and gun, I've seen "supports" with shotguns and "scouts" with lmgs.

Steps To Reproduce

No idea what causes it, its not two often but I saw it at least 3 times in a few hours of play.

Actual Result
Expected Result

Activities

Armand Neculai

2017-08-24 16:07


  ~0004938

Did you encountered this lately? If so could you please be kind and provide a video :D

karistaja

2017-09-12 20:48

Registered User
  ~0005104

I'm still encountering this on occasion, ill try and get a video.

Weffy13

2017-09-13 00:57

Registered User
  ~0005107

Last edited: 2017-09-13 00:58

View 2 revisions

I think you are referring to players kit switching on the fly. It happens whenever someone switches kits with a dead player's kit. I don't think it's a bug unless the player model is suppose to change every time the player switches kits.

Spitfire

2018-06-14 22:02


  ~0006737

Closing due to inability to reproduce. It can happen on live servers when someone picks up a kit from the ground. Please reopen with a video if you experience it again.