View Issue Details

IDProjectCategoryPrivateLast Update
0004029Battlefield 1Progression/UnlocksNo2017-12-05 13:37
Reporterdmccar1001 
SeverityMinorReproducibility@[email protected] 
Status ClosedResolutionDuplicate 
PlatformConsoleOSXbox 
Product VersionUpdate 20062017 - Nivelle Nights Update 
Fixed in Version 
Summary0004029: MLE 1903 Unlocked but now only available for Tanker Class
Description

Unable to equip the MLE 1903 Extended for the Pilot class -- says the Assignment must be completed. I unlocked in March and used last prior to the June update. Now the MLE 1903 is not selectable for the pilot BUT it is selectable for the Tanker Class (unlocked). I have 96 kills with the weapon as a pilot and tanker.

Steps To Reproduce

Select a plane to spawn in and customize loadout -- MLE 1903 Extended not selectable and shows 0% of assignment complete. Select a tank and customize loadout -- MLE 1903 Extended is available and able to be equipped and used in game. Previous to June update was also able to equip and use for pilot class.

Actual Result
Expected Result

Relationships

duplicate of 0003585 FixedEA_RedSpoder MLE 1903 extended unlocked but cannot be selected in load out 
related to 0003501 Closed MLE 1903 Extended (Tanker/Pilot Weapon) Re-Locks Every Game Until 1 Landship Kill Achieved 
related to 0003688 Closed Mle 1903 wont show as unlocked but can use 

Activities

Armand Neculai

2017-07-06 18:13


  ~0004469

Try to equip it form quick loadout menu in deploy screen

EA_RedSpoder

2017-12-05 13:37


  ~0005745

Dupe of 0003585