View Issue Details

IDProjectCategoryPrivateLast Update
0004017Battlefield 1VehiclesNo2018-01-17 13:47
ReporterKingLazarusz 
SeverityMajorReproducibilitySometimes 
Status ClosedResolutionDuplicate 
PlatformPCOSWindows 
Product VersionLive Service Update 06292017 
Fixed in Version 
Summary0004017: Main tank gun doesn't do damage to enemy tanks
Description

Take a look at this video: https://www.youtube.com/watch?v=XL4su7oPuq8

This happens from time to time. Main tank cannon sometimes just wouldn't do damage to other tanks no matter the angle. A fix for it is to get out of the tank and get back in, but obviously, you are at a huge disadvantage of losing a fight or getting your tank stolen. I had too many huge streaks crushed, because of this bug and I would like for it to be finally fixed.

Steps To Reproduce

Play with a tank.

Actual Result
Expected Result

Relationships

duplicate of 0003884 Fixed Tank bug (no hit detection) from latest May update 

Activities

KingLazarusz

2017-07-05 18:52

Registered User
  ~0004453

No feedback on this one? I thought this was crucial to the game, apparently not...

KingLazarusz

2017-07-12 18:04

Registered User
  ~0004516

Any updates?

Spiroku

2017-07-12 18:52

Registered User
  ~0004518

Another Desync bug, Its happen time to time. How much latency "ping" do you play normally?

Relate: https://www.bftracker.com/view.php?id=3818

KingLazarusz

2017-07-15 15:47

Registered User
  ~0004536

@Spiroku usually my ping is around 30-50ms

humphreybc

2017-07-28 07:22

Registered User
  ~0004649

See video below. I hit this St Chamond once on the tracks and four more times on the nose. Had just come out of spawn. Start of the round. No fighting beforehand. I've had this problem quite a few times over the past week.

https://streamable.com/vmwlq