View Issue Details

IDProjectCategoryPrivateLast Update
0003961Battlefield 1Controls/InputNo2018-02-01 19:18
Reporterjimbojnr81 
SeverityMajorReproducibilityAlways 
Status TriageResolutionOpen 
PlatformPCOSWindows 
Product Version 
Fixed in Version 
Summary0003961: No Repair Tool when spawning in any vehicle
Description

Every time i spawn into any new vehicle (Tank, truck, plane) as the driver i do not have the repair tool. When i exit the vehicle i notice that the 2 gadget slots have been taken up by tank grenades. This has only started happening today and it is happening every single time i spawn in a vehicle. I have restarted the game, reinstalled the game. i am at a loss.

Actual Result
Expected Result

Relationships

has duplicate 0004009 Closed No Repair Tool when spawning in any land vehicle 
related to 0004027 Triage Self repair tank is not working 

Activities

Armand Neculai

2017-06-18 11:45


  ~0004382

Could you provide a video of this issue ? i was unable to reproduce it . Always got spawned with a repair tool in my inventory.

jimbojnr81

2017-06-21 08:18

Registered User
  ~0004400

Last edited: 2017-06-21 08:20

View 3 revisions

Here is a link to a video i took of the issue i had to upload it to youtube as its bigger than the max size you allow here.

https://youtu.be/wWkNbo0JhDY

jimbojnr81

2017-06-21 08:24

Registered User
  ~0004401

also i need to revise the original issue, it's only when i spawn into a tank or truck. I do get the repair tool when I'm in a plane.

jimbojnr81

2017-06-24 09:38

Registered User
  ~0004410

still no change after uninstalling, re-downloading and installing again.

jimbojnr81

2017-07-01 02:32

Registered User
  ~0004433

so still not working.... going to start opening new issues pretty soon as it looks like this one isn't being looked at...

Armand Neculai

2017-07-13 16:41


  ~0004527

This seems to occur only in Pre-round . Does it occur during actual gameplay ?

jimbojnr81

2017-07-20 08:33

Registered User
  ~0004591

Yeah, it occurs during actual game play every time.

jimbojnr81

2017-08-12 10:06

Registered User
  ~0004747

Any update on this bug? It's been nearly 2 months and still no fix.

zwolseballetjes

2017-08-16 18:50

Registered User
  ~0004825

Pls fix this bug. Its allmost impossible to use any tank

zwolseballetjes

2017-08-21 19:36

Registered User
  ~0004863

With the august update this bug is still not fix. Is there any chance this bug get fix this year??

zwolseballetjes

2017-08-27 15:53

Registered User
  ~0004950

pls look at this video. https://www.youtube.com/watch?v=zL1K7BmYZh4
This player has the same problem as me and now hi have is wrench back,
see also https://forums.battlefield.com/en-us/discussion/117149/missing-wrench-in-my-tanks-drivers-layout-could-not-repair-vehicle-inside-for-months#latest

zwolseballetjes

2017-09-12 17:36

Registered User
  ~0005100

jimbojnr81.
I have my wrench back. And not with the help of dice because they are not able to fix this. This you must do. Go to an empty server. Spawn in a tank and step out of the tank. Then quit the game and go to an empty server which have calvery. Then select calvery and now you can change the loadout into 1 wrench and 1 AT grenade. Good luck

rusdar

2018-01-31 20:38

Registered User
 

2144214124.png (2,861,099 bytes)

rusdar

2018-01-31 20:38

Registered User
  ~0006141

Last edited: 2018-01-31 20:40

View 3 revisions

when will solve the problem?

https://forums.battlefield.com/en-us/discussion/135335/there-is-no-repair-tool-for-the-pilot
https://answers.ea.com/t5/Tehnicheskie-voprosy/No-repair-tool-in-pilot-class/td-p/6608860
https://answers.ea.com/t5/Bug-Reports/No-repair-tool-in-pilot-class/m-p/5872681#M2546

Disappeared repair tool (# 3 in the inventory of the pilot) can not repair the technique in the air on the key "x"
See my screenshots. To try to do the impossible, because I do not have a window of gadgets from the pilot, I do not have to choose a repair tool, I can not remove the missile.
I can not repair the equipment in the air, the message "x" -failure does not light up on the bottom right. I can only use the unique features of "wing repair", "acceleration".
A month ago everything was fine, with the driver's mechanic in ground technology, there is an instrument and I can fix on "x", the purpose of the key was checked, in an airplane, there is an "x"
Because of this, do not go through the task of "repairing an airplane in the air"
There is no repair tool for the pilot. You can not put it, either. We can not customize unique classes.
Colleagues, I can not repair an airplane \ bomber \ fighter in the air. Ground-based equipment is repaired as standard on "X", there are no problems. The key bindings were reset.
I can repair only the "wing" and the unique abilities of the airplane to use. When the airplane is hit, it does not light up on the right below the "X-Fix".
P.S. earlier (about 3 weeks ago everything was like everyone else).



123444.png (3,927,357 bytes)
11.jpg (80,252 bytes)
11.jpg (80,252 bytes)
12.JPEG (201,700 bytes)
12.JPEG (201,700 bytes)
13.png (1,634,630 bytes)
14.png (1,438,750 bytes)
16.jpg (48,316 bytes)
16.jpg (48,316 bytes)

rusdar

2018-02-01 19:14

Registered User
  ~0006154

Last edited: 2018-02-01 19:18

View 5 revisions

I regret, but the conflict is written, the instrument does not appear in the game in the inventory

https://preview.ibb.co/b1UWpR/15.png
https://preview.ibb.co/b7u33m/113.png
https://preview.ibb.co/fUBcUR/123444.png
https://preview.ibb.co/eggNw6/2144214124.png

Posted this before but got no feedback. Let me know if this fix works:

The tanker and pilot class are hidden on the companion website. Normally any changes done on it does not get pushed trough so it might not work but maybe when you have this bug it will.
Go to the companion website: https://www.battlefield.com/companion

Go to loadouts and click on any loadout. For example click on the primary for assault. Then change the url from 0/0/0 to /5/0/2
Click on the repair tool and hit equip.
For the tanker it is 4/0/2



15.png (562,507 bytes)
113.png (716,495 bytes)
123444-2.png (558,415 bytes)
2144214124-2.png (708,718 bytes)