View Issue Details

IDProjectCategoryExploit/GlitchLast Update
0003955Battlefield 1EngineNo2017-07-26 13:59
Reporteri40oz 
SeverityMajorReproducibilitySometimes 
Status InvestigatingResolutionOpen 
PlatformConsole 
Product VersionUI Update 05182017 
Fixed in Version 
Summary0003955: Cavalry can't pick up health packs while mounted
DescriptionWhen riding at full gallop the rider does not register collecting a health pack. Please see my video of the bug:

https://youtu.be/f_-HZhfv0q8

You can see I ride directly over the medpack at 1 seconds and at 6 seconds.

There is a thread on the BF1 forums located here: https://forums.battlefield.com/en-us/discussion/109340/horse-silent-nerf-again/ It is happening to the community at large. I have only noticed it recently (in the past few days) so I assume it has to do ping rates and interpolation, or something in the netgear code. I only play conquest, so you may want to start there.
Steps To ReproducePlease ride the horse on a regular internet connection, with moderate pings. While mounted, simply drop a health pack on uneven ground (it happens on level ground as well) and ride over it at full gallop. The bug began occurring after the May update and I believe it is due to one of the following two points.
 
-Fixed server side hit registration interpolation.
-Extended Fighter and Attack Plane elevator flap scaling curves to better cover the entire speed range.

One thing to note is that I have confirmed this issue is happening on both PS4 and Xbox. Also, I believe it has to do with interpolation and/or tick rate. I assume that this is the case because when moving at slower speeds (e.g. dismounted) there is no issue with picking up the health.

Activities

Armand Neculai

2017-06-19 18:31


  ~0004387

The med pack should be on the same level as you are . try to throw a med pack on a building or a wall situated at the same level as you while on the horse and please tell me if it works

i40oz

2017-06-19 19:51

User
  ~0004388

Hi Armand,

I will test again on even terrain but I don't think it will work. Maybe I can test it at ballroom blitz in the courtyard since that is very flat and even. But I believe the issue has to do with the netcode or interpolation. It's probably frame-clipping when on the horse. So for example, your horse isn't registering as walking over it because it's only registering being in a spot every 3 feet or so. Which would also explain missing people on the sword when you swing right over them, etc.

I played again this weekend and didn't have any issues on certain servers, and lots of issues on other servers. There is also another bug where the health/ammo icons' opacity almost completely disappears and makes it very difficult to see on the ground, it may be related to the same thing as this bug. That opacity bug was happening pre-patch though.

Armand Neculai

2017-06-19 21:43


  ~0004391

I tried to reproduce this issue and when going over a med pack the cavalry did not receive healing but when i put the med pack on the same level as me, while riding the horse , the med pack worked right away .

forkbeard84

2017-06-20 21:50

User
  ~0004399

Hey Armand, I am glad you for investigating this. I agree with this bug report and have experienced the bug first hand. Cavalry has always been able to run or walk over a health pack on the ground and pick it up to receive healing for the soldier. I am uncertain about having the health pack at the same level as the soldier as I've never tried to heal that way. So that should be a separate issue as that is not what is being complained about here.

Ever since the May update, its been very hard to drop health on the ground, run past it, turn around and run back over it and have it heal you. Many horse users on the forums agree that there is a problem picking up health now. Now if you run or even walk over a health pack it sometimes will not trigger healing even though it looks like you are right on top of it. To me, its like May update reduced the healing radius of the health pack. Anyways please let me know if I can assist in any way.

i40oz

2017-06-21 13:55

User
  ~0004404

Hi Armand,

Please see the video below:

https://youtu.be/SzlS9ZNcn-4

As you can see I attempt to go over multiple healthpacks multiple times at even ground with no luck.

Armand Neculai

2017-07-13 17:49


  ~0004531

Talked with some guys and come to the conclusion this is not an issue . If the med pack has functionality while at the same level as the cavalry its ok . And i tried different scenarios in which all the time if the med pack was at the same height as the cavalry (meaning the character not the horse) it works

kespec

2017-07-26 13:59

User
  ~0004635

Hello i admire your enthusiasm and hardwork but this is indeed an issue for us hardcore cavalry players.

I want to point out why this is an issue.

1. it was working as intended before the may patch. I want to note that before the patch, it was literally impossible for me to get a roadkill, i would just phase through people with zero damage(60-70ping). the patch finally fixed it, it also broke how medpacks interacted with the horse.

2. It's too inconsistent to be deemed "working as intended". because you can pick medpacks from the ground roughly 50% of the time, i have tested extensively and I believe there is no pattern as to why medpack wont interact in different scenarios.

3. if it's your intention to force the cavalry to unmount to get healed, then i have to say this is an unhealthy mechanic since it is one of the plethora of reasons why people abandon their horse and fight on foot. fighting on horseback has become a real pain