View Issue Details

IDProjectCategoryPrivateLast Update
0003501Battlefield 1Progression/UnlocksNo2017-12-05 13:37
ReporterElite1111111111 
SeverityMajorReproducibility@[email protected] 
Status ClosedResolutionDuplicate 
PlatformConsoleOSXbox 
Product VersionUpdate 03142017 (XP1) 
Fixed in Version 
Summary0003501: MLE 1903 Extended (Tanker/Pilot Weapon) Re-Locks Every Game Until 1 Landship Kill Achieved
Description

Title. I have completed the challenge for the MLE 1903 Extended, but it relocks every single game. Once I earn one Landship kill, it unlocks for the rest of the game.

Steps To Reproduce

View Tanker Pilot class after you've already unlocked the MLE 1903 Extended. Not sure what happens if you already have it equipped.

Actual Result
Expected Result

Relationships

duplicate of 0003585 FixedEA_RedSpoder MLE 1903 extended unlocked but cannot be selected in load out 
has duplicate 0003760 Closed Mle 1903 extended is not recognizing progression 
related to 0004029 Closed MLE 1903 Unlocked but now only available for Tanker Class 
related to 0003688 Closed Mle 1903 wont show as unlocked but can use 

Activities

EA_RedSpoder

2017-12-05 13:37


  ~0005746

Dupe of 0003585