View Issue Details

IDProjectCategoryPrivateLast Update
0003491Battlefield 1Progression/UnlocksNo2017-12-05 13:37
ReporterKoRnTuNeS 
SeverityMajorReproducibility@[email protected] 
Status ClosedResolutionDuplicate 
PlatformPS4OSPlaystation 
Product Version 
Fixed in Version 
Summary0003491: Mle 1903 Extended Can't Equip Bug
Description

I got 75 kills with a landship vehicle and equipped after revive on tanker class, but I can't equip on pilot class. It's show you need 75 landship vehicle kills. I playing on PS4

http://i.imgur.com/3aGqs0j.jpg
http://i.imgur.com/cJbZKry.jpg
http://i.imgur.com/qtna5He.jpg
http://i.imgur.com/eK0pUkk.jpg

It's a bonus bug
http://i.imgur.com/quTaCiO.jpg

Actual Result
Expected Result

Relationships

duplicate of 0003585 FixedEA_RedSpoder MLE 1903 extended unlocked but cannot be selected in load out 
has duplicate 0004124 Closed MLE Extended 
has duplicate 0003688 Closed Mle 1903 wont show as unlocked but can use 

Activities

Elite1111111111

2017-04-04 13:10

Registered User
  ~0003925

Since my post of the issue doesn't seem to be showing up for some reason, I've found that it unlocks again if I earn another landship kill, but only stays unlocked for a single game.

Anthonio

2017-04-08 01:38

Registered User
  ~0003959

For me I am able to select the pistol in the dropdown menu from the spawn screen. It is indeed bugged in the customize menu.

Leopoldo_94

2017-04-08 08:38

Registered User
  ~0003961

same here, unlocked it but can't equip it in game

Someguy12121

2017-08-22 21:12

Registered User
  ~0004909

I can equip it via the quick select on the spawn screen however it cannot be equipped in the customize menus.

EA_RedSpoder

2017-12-05 13:37


  ~0005747

Dupe of 0003585